提供7*24专业Sybase数据库远程及现场技术支持,Sybase ASE及Sybase SQL Anywhere数据库修复服务,
请联系电话: (微信),QQ: 289965371!
We supply technical support for Sybase ASE and Sybase SQL Anywhere, also have many years of experience in recovering data from damanged Sybase devices.
Please contact us:
Phone:
Wechat: 13811580958
QQ: 289965371 联系我们获取数据库技术支持!
Email: 289965371@qq.com
扫描下方微信,联系我们:
扫描雨翰数据恢复官方微信获取专业数据库恢复服务

 

随着Sybase被完全整合到SAP下,Sybase原来的支持网站被SAP Support Portal取代。
只有购买了SAP服务的用户才能使用账号登录SAP Support Portal进行介质下载、补丁升级、报Incident等。
目前,原Sybase所有产品(包括:Adaptive Server Enterprise、Sybase IQ、Replication Server、PowerDesigner等)的官方手册仍然可以从https://infocenter.sybase.com/help/index.jsp进行浏览或下载。暂不清楚该网站https://infocenter.sybase.com/help/index.jsp何时会被完全迁移到SAP Support上!
Sybase官方手册英文版有html和pdf两种格式,而中文版手册只有pdf一种格式。为了国内Sybase用户更方便、快捷地搜索Sybase常见产品的官方手册内容,特将中文版Sybase官方手册转为html格式!
Sybase产品官方手册中文版的html格式所有内容的版权归SAP公司所有!本博客站长是Sybase数据库的铁杆粉丝!

如有Sybase数据库技术问题需要咨询,请联系我!

  QQ :289965371 联系我们获取数据库技术支持!
  Email:

以下官方手册为SAP IQ 16.0 SP03中文版:

  1. SAP Sybase IQ 简介
  2. 新功能摘要
  3. IQ 发行公告(linux)
  4. IQ 快速入门(unix)
  5. 安装和配置指南(linux)
  6. 管理:备份、恢复和数据恢复
  7. 管理:数据库
  8. SAP Sybase IQ 错误消息
  9. 管理:全球化
  10. IQ 许可选项指南
  11. 管理:装载管理
  12. IQ 迁移
  13. 管理:Multiplex
  14. 性能和调优指南
  15. IQ 编程
  16. 参考:构件块、表和过程
  17. 参考:语句和选项
  18. 管理:内存行级版本控制
  19. 管理:空间数据
  20. IQ 非结构化数据分析
  21. 用户定义的函数
  22. 管理:用户管理和安全
  23. 实用程序指南

 


< 上一个 | 内容 | 下一步 >

使用 CREATE TABLE 语句时的注意事项 创建表以实现兼容性时,请注意以下兼容性注意事项:空值处理、检查约束、参照完 整性、缺省值、标识列、计算列、临时表和表位置。 ‌


列中的 NULL

为实现 NULL 的兼容处理:

• 如果列定义中没有声明 NOT NULL,则 SQL Anywhere 和 SAP Sybase IQ 假定列 可以为空值。可通过将数据库选项 ALLOW_NULLS_BY_DEFAULT 设置为与 Transact- SQL 兼容的设置 OFF 来更改此行为。

• SQL Anywhere 和 SAP Sybase IQ 假定 BIT 列不能为 NULL。

• 如果未声明 NULL,Adaptive Server 假定列不能为空值。


检查约束

SAP Sybase IQ 强制对基表、全局临时表和局部临时表以及用户定义的数据类型执行 检查约束。用户可以记录检查完整性约束违规,并指定在 LOAD 语句回退前可以发生 的违规数。

SAP Sybase IQ 不允许创建它无法评估的检查约束,如由用户定义的函数、代理表或非 SAP Sybase IQ 表组成的检查约束。对于那些无法评估的约束,当在 LOAD、INSERT 或 UPDATE 语句中首次使用定义了相应检查约束的表时,系统便会检测到这些约束。SAP Sybase IQ 不允许使用包含以下内容的检查约束:

• 子查询

• 指定主机语言参数、SQL 参数或列作为数据值目标的表达式

• 集函数

• 对非确定性函数或修改数据的函数的调用

Adaptive Server 和 SQL Anywhere 强制执行 CHECK 约束。SQL Anywhere 允许在检查 约束中使用子查询。

SAP Sybase IQ 支持允许将约束封装在数据类型定义中的用户定义数据类型。


参照完整性约束

支持强制执行完整性的操作,如下所示:

• SQL Anywhere 支持所有 ANSI 操作:SET NULL、CASCADE、DEFAULT、 RESTRICT。

• Adaptive Server 支持其中的两个操作:SET NULL、DEFAULT。

image

注意: 通过使用触发器而非参照完整性可在 Adaptive Server 中实现 CASCADE。

image

• SAP Sybase IQ 仅支持 RESTRICT 操作。

• SAP Sybase IQ 不支持 NOT NULL FOREIGN KEY。

• SAP Sybase IQ 具有列不能同时作为候选键和外键的限制。


列中的缺省值

缺省值支持有如下区别:

• Adaptive Server 和 SQL Anywhere 支持为列指定缺省值。

• 仅 SQL Anywhere 支持 DEFAULT UTC TIMESTAMP。

• SAP Sybase IQ 支持为列指定缺省值(特殊值 DEFAULT UTC TIMESTAMP 和 DEFAULT CURRENT UTC TIMESTAMP 除外)。SAP Sybase IQ 还会忽略 DEFAULT_TIMESTAMP_INCREMENT 数据库选项的设置。


标识列

标识列支持有如下区别:

• SAP Sybase IQ 支持 IDENTITY 或 DEFAULT AUTOINCREMENT 作为缺省值。SAP Sybase IQ 支持精度为任意值、小数位数为 0 的任何数值类型的标识列,且该列可 以为 NULL。SAP Sybase IQ 标识列必须为正值,且受数据类型范围的限制。SAP Sybase IQ 支持每个表一个标识列,并要求将数据库选项 IDENTITY_INSERT 设置为 显式插入和更新的表名称。要删除含 IDENTITY 列的表,不能将 IDENTITY_INSERT 设置为指向该表。添加标识列时,该表可以包含数据。使用 SELECT INTO 派生的 表不具有标识/自动增量列。SAP Sybase IQ 视图不能包含 IDENTITY/DEFAULT AUTOINCREMENT 列。

• SQL Anywhere 支持 AUTOINCREMENT 缺省值。SQL Anywhere 支持小数位数和精 度为任意允许值的任何数值类型的标识列。标识列值可以是正数、负数或零,受 数据类型范围的限制。SQL Anywhere 支持每个表有任意数量的标识列,但不要求 使用 identity_insert 执行显式插入、删除和更新。添加标识列时,表必须为空。可将 SQL Anywhere 标识列改为非标识列,也可以将非标识列改为标识列。可在 [[unresolved text-ref: SQL Anywhere]] 视图中添加或删除 AUTOINCREMENT 列。

• Adaptive Server 支持每个表一个标识列。Adaptive Server 标识列只能是小数位数为 0、最大精度为 38 的数值数据类型。它们必须为正数,且受数据类型范围的限制, 也不能为空值。Adaptive Server 要求使用 identity_insert 执行显式插入和删除,但 不要求使用该命令执行标识列的更新。添加标识列时,该表可以包含数据。Adaptive Server 用户不能显式设置为标识列选择的下一个值。Adaptive Server 视图不能包含 IDENTITY/AUTOINCREMENT 列。在某些条件下使用 SELECT INTO 时,如果要 从中选择内容的表中包含标识/自动增量列,Adaptive Server 会允许结果表中也包 含这些列。


计算列

计算列支持有如下区别:

• SQL Anywhere 支持能够创建索引的计算列。

• Adaptive Server 和 SAP Sybase IQ 不支持计算列。


临时表

您可以通过以下方法创建临时表:在 CREATE TABLE 语句中的表名前加上井号 (#) 但 不指定所有者。这些临时表是 SAP Sybase IQ 声明的临时表,只能在当前连接中使 用。


定位表

Adaptive Server 和 SAP Sybase IQ 中表的实际放置方式有所不同。SAP Sybase IQ 支持 ON segment-name 子句,但 segment-name 指的是 SAP Sybase IQ dbspace。


sp_iqstatus 过程的输出

image

Sybase IQ (TM) Copyright (c) 1992-2013 by SAP AG or an SAP affiliate company. All rights reserved.

Version: 16.0.0.562/130821/P/Mainline/Sun_x64/OS 5.10/64bit/ 2013-08-21 06:15:41

Time Now: 2013-08-21 06:27:14.150

Build Time: 2013-08-21 06:15:41

File Format: 23 on 03/18/1999 Server mode: IQ Server

Catalog Format: 2

Stored Procedure Revision: 1 Page Size: 65536/4096blksz/16bpp Number of Main DB Files: 2

Main Store Out Of Space: N

Number of Cache Dbspace Files: 5 Number of Shared Temp DB Files: 0 Shared Temp Store Out Of Space: N Number of Local Temp DB Files: 1 Local Temp Store Out Of Space: N DB Blocks: 1-25600 IQ_SYSTEM_MAIN

DB Blocks: 522208-547807 MainUser

Cache Dbspace Blocks: 1-5120 ssd_dev_1

Cache Dbspace Blocks: 522208-527327 ssd_dev_2 Cache Dbspace Blocks: 1044416-1049535 ssd_dev_3 Cache Dbspace Blocks: 1566624-1571743 ssd_dev_4 Cache Dbspace Blocks: 2088832-2093951 ssd_dev_5 Local Temp Blocks: 1-25600 IQ_SYSTEM_TEMP

Create Time: 2013-08-21 06:27:05.444

Update Time: 2013-08-21 06:27:14.035

Main IQ Buffers: 1588, 100Mb Temporary IQ Buffers: 1588, 100Mb

Main IQ Blocks Used: 5250 of 38400, 13%=20Mb, Max Block#: 5313 Cache Dbspace IQ Blocks Used: 197 of 25600, 0%=0Mb, Max Block#: 0 Shared Temporary IQ Blocks Used: 0 of 0, 0%=0Mb, Max Block#: 0 Local Temporary IQ Blocks Used: 65 of 12800, 0%=0Mb, Max Block#: 0 Main Reserved Blocks Available: 12800 of 12800, 100%=50Mb

Shared Temporary Reserved Blocks Available: 0 of 0, 0%=0Mb

Local Temporary Reserved Blocks Available: 12800 of 12800, 100%=50Mb IQ Dynamic Memory: Current: 292mb, Max: 308mb

Main IQ Buffers: Used: 18, Locked: 0 Temporary IQ Buffers: Used: 4, Locked: 0

Main IQ I/O: I: L459/P9 O: C21/D33/P22 D:1 C:100.0


image

Temporary IQ I/O: I: L320/P0 O: C54/D59/P8 D:50 C:100.0

Other Versions: 0 = 0Mb

Active Txn Versions: 0 = C:0Mb/D:0Mb Last Full Backup ID: 0

Last Full Backup Time: Last Backup ID: 0

Last Backup Type: None Last Backup Time:

DB Updated: 0

Blocks in next ISF Backup: 0 Blocks: =0Mb Blocks in next ISI Backup: 0 Blocks: =0Mb IQ large memory space: 2048Mb

IQ large memory flexible percentage: 50 IQ large memory flexible used: 0Mb

IQ large memory inflexible percentage: 90 IQ large memory inflexible used: 0Mb

IQ large memory anti-starvation percentage: 50 DB File Encryption Status: OFF

RLV memory limit: 2048Mb RLV memory used: 0Mb




--------------------------------------华丽的分割线-------------------------------------------------------------------------

Sybase SQL Anywhere数据库恢复工具ReadASADB:

之前就已经研发成功了能够从Sybase SQL Anywhere的DB文件中恢复数据的工具: ReadASADB。
此工具支持ASA v5.0, v6.0, v7.0, v8.0, v9.0, v10.0, v11.0, v12.0, v16.0, v17.0等版本。
能够从损坏的SQL Anywhere数据文件(.db)和UltraLite数据文件(.udb)上提取数据的非常规恢复工具。
恢复Sybase SQL Anywhere的工具在国内处于领先水平。

Sybase SQL Anywhere数据库恢复工具ReadASADB功能
能够从损坏的SQL Anywhere数据文件(.db)和UltraLite数据文件(.udb)上提取数据的非常规恢复工具
  1. 适用于所有的SQL Anywhere版本    包括:5.x,6.x,7.x,8.x,9.x,10.x,11.x,12.x,16.x,17.x
  2. 适用于所有的UltraLite版本
  3. 能够恢复出来表结构和数据
  4. 能够恢复自定义数据类型
  5. 能够恢复存储过程等对象的语法
  6. 能够导出到目标数据库
  7. 能够导出到SQL文件并生成导入脚本
  8. 支持多种字符集,包括:cp850、cp936、gb18030、utf8等
  9. 能够恢复未加密或者简单加密类型的数据
  10. 简单易用
  11. 限制:不支持AES加密的数据文件
请参考:研发成功了从Sybase SQL Anywhere的DB文件上恢复数据的工具
            SQL Anywhere数据库非常规恢复工具ReadASADB使用介绍

Sybase SQL Anywhere数据库恢复工具ReadASADB适用场景

各种误操作:

  1. 误截断表(truncate table)
  2. 误删除表(drop table)
  3. 错误的where条件误删数据
  4. 误删除db或log文件
  5. 误删除表中的字段

Sybase SQL Anywhere数据库恢复工具ReadASADB的应用场景:

1.因为物理磁盘故障、操作系统、系统软件方面或者掉电等等原因导致的Sybase SQL Anywhere数据库无法打开的情况;
2.误操作,包括truncate table,drop table,不正确的where条件导致的误删除等;
Sybase SQL Anywhere无法打开时,比较常见的错误是:Assertion failed。
如:
1、Internal database error *** ERROR *** Assertion failed:201819 (8.0.1.2600) Checkpoint log: invalid bitmap page -- transaction rolled back
2、Internal database error *** ERROR *** Assertion failed:201819 (8.0.1.2600) Page number on page does not match page requested -- transaction rolled back
3、Internal database error *** ERROR *** Assertion failed:200502 (9.0.2.2451) Checksum failure on page 23 -- transaction rolled back
4、File is shorter than expected
5、Internal database error *** ERROR *** Assertion failed: 201116 Invalid free list index page found while processing checkpoint log -- transaction rolled back
6、*** ERROR *** Assertion failed: 51901 Page for requested record not a table page or record not present on page
7、*** ERROR *** Assertion failed: 201417 (7.0.4.3541) Invalid count or free space offset detected on a table page
8、Internal database error *** ERROR *** Assertion failed: 201425 (8.0.3.5594) Invalid count or free space offset detected on a free list page -- transaction rolled back.
9、Internal database error *** ERROR *** Assertion failed: 100702 (8.0.1.2600) Unable to modify indexes for a row referenced in rollback log -- transaction rolled back


-------------------------------------------------------------------------------------------

Sybase ASE数据库恢复工具READSYBDEVICE:

一个不依赖数据库管理系统、直接从Sybase数据库设备文件上提取数据的业内领先的恢复工具!
能够从损坏的Sybase ASE设备文件(.dat)上提取数据的非常规恢复工具。

Sybase ASE数据库恢复工具READSYBDEVICE的主要功能:

  1. 被勒索病毒加密数据文件及备份文件情况下的恢复;
  2. 系统崩溃只剩下数据文件的情况下的恢复,甚至数据库文件不存在而只有损坏的备份文件情况下的恢复;
  3. 因断电、硬盘坏道等造成数据库文件损坏情况下的恢复;
  4. delete数据恢复、误update数据恢复、误删除表(drop)恢复、误truncate表恢复 等;
  5. 各种Sybase内部系统表损坏、索引错误的修复;
  6. master数据库损坏而无法正常运行情况下的恢复;
  7. Sybase数据库被标记为可疑,不可用等情况的恢复;
  8. Sybase数据库中数据文件内部出现坏块情况下的恢复;
  9. Sybase数据库无数据文件但有日志文件的情况下的恢复;
  10. Sybase数据库只有数据文件无任何日志文件的情况下的恢复;
  11. Sybase数据文件被误删除情况下的碎片提取恢复;
  12. 磁盘阵列上的Sybase数据库被误格式化情况下的数据库恢复;
  13. 数据库sysobjects等系统表损坏无法正常应用情况下的恢复;
  14. Sybase数据库还原数据库出现失败情况下的恢复;
  15. Sybase数据库只剩下损坏的备份文件情况下的恢复。

Sybase ASE数据库恢复工具READSYBDEVICE支持的版本:

Sybase ASE 11.0.x,11.5.x,11.9.x,12.0.x,12.5.x,15.0.x,15.5.x,15.7.x,16.0.x


-------------------------------------------------------------------------------------------

SQL Server数据库恢复工具SQLRescue:

一个不依赖数据库管理系统、直接从SQL Server数据库文件上提取数据的业内领先的恢复工具!
能够从损坏的SQL Server数据库文件(.mdf)上提取数据的非常规恢复工具。

SQL Server数据库恢复工具SQLRescue的主要功能:

  1. 系统崩溃只剩下数据文件的情况下的恢复,即无日志文件或者日志文件损坏情况下的恢复;
  2. 断电导致数据库文件损坏情况下的恢复;
  3. 硬盘坏道造成数据库损坏情况下的恢复;
  4. 数据文件内部存在坏页情况下的恢复;
  5. 企业管理器误删除数据表记录,管理软件误删除数据表记录的恢复;
  6. 并闩锁错误、格式化、误删除后导致软件不能使用的情况;
  7. 无法读取并闩锁页sysindexes失败情况下的修复;
  8. 数据文件被误删除情况下的碎片提取恢复;
  9. 系统表损坏、索引错误、误删除数据库表、删除记录的数据找回;
  10. master数据库损坏而无法正常运行情况下的恢复;
  11. 数据文件无法附加情况下的数据恢复;
  12. 数据库被标记为可疑,质疑,不可用等情况的恢复;
  13. 数据库sysobjects等系统表损坏情况下的恢复;
  14. 数据被误(drop、delete、truncate)删除表数据的恢复,误update后的数据恢复等;
  15. 还原时报一致性错误,错误823等情况下的数据恢复,各种错误提示的数据库文件修复;
  16. 数据库被误格式化等情况下的数据库恢复;
  17. 日志收缩造成数据库损坏情况下的恢复;
  18. 仅剩损坏的备份文件情况下的恢复。

SQL Server数据库恢复工具SQLRescue技术特点:

只要SQL Server数据库的数据文件存在,我们就有办法帮您从数据文件中找回重要数据。
  1. 从数据文件中直接恢复数据
  2. 不能附加时直接恢复数据并生成新的数据库
  3. 系统表损坏的数据库修复
  4. 快速修复SQL 823错误、连接中断错误

SQL Server数据库恢复工具SQLRescue支持的版本:

Microsoft SQL Server 7.0, 2000, 2005, 2008, 2008R2, 2012, 2014, 2016, 2017,2019。
+-------------------------------------华丽的分割线-------------------------------------------------------------------------